Daniel Harris

Coding, The Cloud, and Tech

27. June 2013 00:40
by Daniel Harris

Surface RT - Compression Artifacts (Pixelation) during video playback

27. June 2013 00:40 by | 0 Comments

Thought I would quickly post this to save others the possible headache of figuring out why their Surface RT suddenly starting showing compression artifacts during video playback. In my case other apps, including some of the more demanding games continued to run fine. The issue seems to be caused by the May firmware update. To be sure I have refreshed the Surface a number of times, and it's always after that update the problem comes back again. The problem affects video playback in most apps, including embedded videos in web pages, within the Netflix app, and when playing local video files from the hard drive. At the moment the answer is to just not install that firmware update after doing a PC refresh. I'm hoping not installing the firmware update won't prevent me from trying the 8.1 Preview. I just don't want to start using the Preview until I have working video. I opted to install 8.1 (After taking a USB backup of the old recovery partition) and it didn't fix the issue, neither did any of the recent 8.1 updates. If you find a better solution than just simply not installing the Firmware update, please post in the comments. I've uploaded a video to YouTube showing the problem: http://www.youtube.com/watch?v=Vk9zIkT8Pbo  Hoping to get an answer from Microsoft soon on their forum: http://answers.microsoft.com/en-us/surface/forum/surfwinrt-surfupdate/surface-rt-video-playback-issues-after-firmware/472ea1b8-943f-4d8c-8322-12b38f5e744e?page=2&tm=1373408564916#LastReply  Update - 10/07/2013 There is an ongoing forum thread on the Microsoft Answers website, it looks as though we may get an answer here at some point. Microsoft Community Forum | Surface RT Video Playback Issues After Firmware Update It also looks as though the Surface Twitter account are aware of a problem. Unfortunately the answer is still to "stay tuned" for a fix. @danieltharris Thanks for following up. My apologies again for the inconvenience. Please stay tuned! — Surface (@surface) July 10, 2013   I've also heard that the July Firmware update was supposed to resolve this issue, but word on various blogs is that the firmware update has been pulled for the time being. No explanation yet as to why but people have said they aren't seeing on either RT 8 or RT 8.1. Personally I can only say i've not yet seen it on 8.1 as I only have the one Surface RT device.